Walther Tactical Pro auf Vordermann bringen

Sirad

Mitglied
Hallo,
Hier mein erster "Modding-" bzw. Reparaturversuch.
Ich hab eine defekte Walther Tactical Pro bekommen und will diese nun auf Vordermann bringen.

In erster Linie steht die Reperatur, in zweiter dann das Modding (dazu später).

Den "defekt" habe ich bereits ausgemacht, das Gewinde beim Schalter hat keinen Kontakt wenn dieser ganz aufgeschraubt ist
(wenn er nur halb aufgeschraubt ist hats einen Wackelkontakt).
Eventuell hat der nichtbeschichtete Ring ganz unten am Gewinde keinen Kontakt zum Schalter?
Hab mir überlegt die Beschichtung vom Gewinde zu entfernen um mehr Kontakt herzustellen,
weis aber nicht wie ich das hinbekomme ohne das Gewinde zu beschädigen. Gäb es da sonst noch ne Möglichkeit das hinzubekommen?

Des Weiteren wird die Lampe beim Betrieb sehr schnell unangenehm warm.
Was mich stutzig macht ist, dass sie nur 170 Lumen hat, und meine PD20 (mit 180 Lumen) selbst nach Stunden weniger warm ist.

Ist bei der Walther evtl eine ineffiziente LED verbaut? Oder kann man die vorhandene Elektronik so modifizieren, dass die LED weniger Licht, aber auch weniger Wärme verursacht?



Wenn die Lampe wieder funktioniert würde ich sie gerne insofern umrüsten, dass sie sowohl mit einem 18650 Akku, als auch mit 2 CR123 Primärzellen funktioniert.
Leider passt der Akku (noch) nicht in den Lampenkörper und ich frage mich ob man das irgendwie "aufdrehen" könnte?

Falls mir bei den bisherigen Fragen jemand helfen könnt, wär ich schon recht glücklich ;)
mfg
Sirad
PS: Anbei 3 Bilder zur veranschaulichung.
iqjm-4-a87f.jpg
iqjm-5-e4da.jpg
iqjm-6-1679.jpg
 
Zuletzt bearbeitet:

Saletti

Mitglied
Wenn Du einen Defekt am Schalter vermutest, wäre ein Bild des (zerlegten) Schalters evtl. hilfreich ;)
Ich kenne nur die ältere Xenon-Variante der Walther Tactical und bei der ist der Schalter ziemlich unkaputtbar. Aber den Beschreibungen nach, die ich gefunden habe, ist bei der pro-Variante da etwas geändert worden.

Das Batterierohr war auch bei der Xenon zu eng für 18650 Akkus. Aber 17670 passen perfekt - wäre dann vielleicht eine Alternative ohne Drehbank.
 

Palladin

Mitglied
Das Kontaktproblem kann verschiedene Ursachen haben, das muß nicht zwingend an den Kontaktflächen liegen.

Ich habe keine Erfahrung mit der Lampe, aber wenn ich mir die Produktbilder im Web anschaue, dann verbleibt ja bei zugedrehter Tailcap noch ein Spalt.
Ergo sollte die blanke Stoßkante ja auf dem Haltering des Clickys ja satt aufliegen, oder?
Versuch als erstes mal den Haltering des Clickys mit Hilfe einer stabilen Pinzette fest anzuziehen und sämtliche Gewinde und Kontaktflächen mit Isopropanol, notfalls Spiritus, gründlich zu reinigen, vielleicht hilft das schon.

Ansonsten hätte ich noch die Feder des Clickys in Verdacht.
Falls Du ein DMM hast, versuche doch mal (im ausgebauten Zustand) den Durchgang des Clickys zu messen, einmal mit entspannter Feder und einmal mit möglichst komprimierter Feder.

Zum Tuning:
Was an Deiner Lampe vermutlich am wärmsten wird, ist der Linearregler Treiber.
Für LiIon ideal, wandelt er aber bei 6V alles über 3,7V im Wärme um :rolleyes:.

Einfachstes Modding: Kauf dir 17670er Akkus. Aufgrund des geringeren Durchmessers sollten diese mit etwas Glück passen.
Den Body aufdrehen zu lassen, sollte im keinem Verhältnis zum Wert der Lampe stehen, falls man nicht gerade einen Dreher um die Ecke kennt, der sich gerade langweilt :D.
 

Sirad

Mitglied
Das mit dem Spiritus probier ich nacher mal wenn ich von der Arbeit komme!

Das bedeutet mit einem anderen Regler wäre evtl mein Hitzeproblem gelöst? Dann werd ich mal DX beglücken :) Ich berichte weiter wenn ich soweit bin.
 

Erzengel

Mitglied
...
Des Weiteren wird die Lampe beim Betrieb sehr schnell unangenehm warm.
Was mich stutzig macht ist, dass sie nur 170 Lumen hat, und meine PD20 (mit 180 Lumen) selbst nach Stunden weniger warm ist.

Ist bei der Walther evtl eine ineffiziente LED verbaut? Oder kann man die vorhandene Elektronik so modifizieren, dass die LED weniger Licht, aber auch weniger Wärme verursacht?

Die LED sieht nach einer XR-E aus. Kennst du das Binning (Q5 oder R2 oder ...)? XR-E gehen bis R2, eventuell kannst du da mit einem Emittertausch noch etwas rausholen. Das lohnt sich aber nur bei nennenswerten Leistungssprüngen. Ein Wechsel auf eine XM-L würde dir deutlich mehr Licht bringen, aber gleichzeitig wird die Lampe flutlastiger und verliert somit an Helligkeit und Reichweite im Spot. Beide Nebenwirkungen würden auch in schwächerer Form bei Verwendung einer XP-G auftreten.
Die XR-E sind nicht so schlecht, was die Effizienz betrifft. Bei einem bloßen Emittertausch wird die Lampe nicht kühler, du bekommst nur etwas mehr Lumen bei selber Laufzeit.

Das bedeutet mit einem anderen Regler wäre evtl mein Hitzeproblem gelöst? Dann werd ich mal DX beglücken :) Ich berichte weiter wenn ich soweit bin.

Wenn du einen anderen Regler verbaust, sollte dieser für den Betrieb mit Cr123 optimiert sein um Wärme zu sparen. Daher ist es einfacher, wie empfohlen einen 17670 Akku zu verwenden.
 
Zuletzt bearbeitet:

Palladin

Mitglied
Emitterwechsel sind immer etwas diffizil.
Ein Binning Upgrade bringt nur selten wirklich was, außer man ist mit dem Tint der verbauten LED richtig unzufrieden.

Einen neueren Emittertyp einzuplanzen birgt halt die Risiken, daß

  1. Die neue LED überhaupt nicht mit dem Reflektor harmoniert, oder
  2. selbst falls der Beam harmonisch ist, einem die neue (i.d.R. flutigere) Beamform nicht behagt.

Den Treiber würde ich auch beibehalten. So verkehrt ist der ganz und gar nicht, solange man bei 3,7V bleibt.
Zudem dürfte es ausgesprochen schwierig werden, einen passenden Ersatz mit geschätztem Durchmesser von gut 20mm aufzutreiben.
Und die bescheidene Pill Konstruktion der Lampe bietet sich wirklich nicht gerade für Adapter Basteleien an.
 

Sirad

Mitglied
Also mit der Helligkeit und allem bin ich zufrieden. Die LED würde ich also ungern tauschen.
Das Binning kenn ich leider nicht. Weis auch nur das, was auf der LED Platine steht.
Bei 3,7V bleiben wird mit Cr123's schwer ;) Also bietet sich da doch ein Akkuwechsel an...
Das mit den 20mm Durchmesser des Treibers kommt schon hin. Nicht gerade die üblichste Größe oder?! ;)


Nachtrag: Der Aktuelle Stand der Dinge:
Der Schalter (und sein Gewinde) hat mich angelogen, beide funktionieren tadellos.
Das Problem war, dass der Treiber so locker im Gehäuse sas, dass der Druck der
Schalterfeder genügte um ihn soweit in den Kopf zu schieben das er keinen Kontakt mehr zum Gehäuse hat.
Behoben wurde dies durch 3 unschöne Lötflecken, welche den Kontakt zwischen Treiber und Gehäuse sicherstellen.
Seitdem funktioniert die Lampe wieder wunderbar und durch die etwas weiter in den Reflektor geschobene LED ist auch der Beam schöner :)

Der Treiber ist ziemlich genau 20mm breit (mit dem Lineal gemessen, was genaueres hab ich nicht)
und an der LED liegen irgendwas um die 3,7V an. Die Stromstärke kann ich nicht messen.
Kennt irgendjemand nen Treiber mit 1 oder 2 Modi, der 18650er/bzw 17670er und CR123's verträgt der da passen könnte?
Kenn mich da leider nicht aus worauf man da alles achten muss...

mfg
Sirad, mit der wieder funktioneirenden Lampe
 
Zuletzt bearbeitet:

Palladin

Mitglied
Mir ist kein Treiber bekannt der

  • 20mm Durchmesser hat,
  • 3,7-6V gleichermaßen gut bedient,
  • zuverlässig und auch noch
  • preislich im Verhältnis zur Lampe vertretbar ist.
Nochmals: Der Treiber an sich ist gar nicht verkehrt.

Investiere lieber das Geld in ein ordentliches Ladegerät und ein paar gute Akkus.
 

Sirad

Mitglied
Alles klar.
Nur nochmal für mein Verständnis ... ;)
Der Treiber der jetzt drin ist, ist wie ne Art Widerstand der alles über 3,7V einfach in Wärme umsetzt.
Also am effektivsten ist es einfach direkt nur 3,7V (oder irgendwas in dem Bereich) anzulegen.
soweit so richtig?
Dann werd ich mich da mal an deinen Rat halten ;) Danke!